Changes

From XDSwiki
Jump to navigationJump to search
68 bytes added ,  15:10, 3 May 2021
Line 168: Line 168:  
A few libraries are needed before CCP4 installation (tcsh is needed by CCP4; most of the others are graphics libraries):
 
A few libraries are needed before CCP4 installation (tcsh is needed by CCP4; most of the others are graphics libraries):
 
  sudo apt install tcsh libqt5opengl5 libqt5printsupport5 libqt5gui5 libxcb-render0 libxcb-shm0 libglu1-mesa libgomp1 binutils
 
  sudo apt install tcsh libqt5opengl5 libqt5printsupport5 libqt5gui5 libxcb-render0 libxcb-shm0 libglu1-mesa libgomp1 binutils
When installing CCP4, let it "modify the environment" for you. If you forgot this, insert a line into your ~/.bashrc :
+
When installing CCP4, let it "modify command line environment" for you (on one of the very first screens of the installation GUI). If you forgot this, insert a line into your ~/.bashrc :
 
  source /opt/xtal/ccp4-7.1/bin/ccp4.setup-sh  
 
  source /opt/xtal/ccp4-7.1/bin/ccp4.setup-sh  
 
afterwards (this is not WSL specific, but is just Linux). I created a file in the Windows filesystem (replace MYUSERNAME with your Windows user name):
 
afterwards (this is not WSL specific, but is just Linux). I created a file in the Windows filesystem (replace MYUSERNAME with your Windows user name):
2,522

edits

Cookies help us deliver our services. By using our services, you agree to our use of cookies.

Navigation menu