Changes

From XDSwiki
Jump to navigationJump to search
205 bytes added ,  16:30, 29 June 2020
Line 147: Line 147:     
==== Libraries and software that the program depends on ====
 
==== Libraries and software that the program depends on ====
 +
In case of '''Fedora''' or Redhat Enterprise Linux ('''RHEL'''; same as CentOS) distributions, you may have to
 +
yum install qt qt-x11
 +
if you get the error message
 +
xdsgui: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory
 +
or similar for libQtCore.so.4.
 +
Similarly, the error message
 +
xds-viewer: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
 +
means that you need to
 +
yum install libpng12
 +
Generally, if in case of RHEL or related distributions you don't know the name of the package, e.g.
 +
  yum provides "*/libQtCore.so.4"
 +
would tell you about it.
 +
 
RedHat Enterprise Linux 8 (CentOS 8) does not seem to provide by default the needed Qt libraries. They can be installed using
 
RedHat Enterprise Linux 8 (CentOS 8) does not seem to provide by default the needed Qt libraries. They can be installed using
 
  dnf install https://extras.getpagespeed.com/redhat/8/noarch/RPMS/getpagespeed-extras-release-8-6.el8.gps.noarch.rpm
 
  dnf install https://extras.getpagespeed.com/redhat/8/noarch/RPMS/getpagespeed-extras-release-8-6.el8.gps.noarch.rpm
Line 157: Line 170:  
In addition, the qt-settings RPM may have to be installed. It is available from EPEL, or also from Fedora 29.
 
In addition, the qt-settings RPM may have to be installed. It is available from EPEL, or also from Fedora 29.
   −
In case of other '''Fedora''' or Redhat Enterprise Linux ('''RHEL'''; same as CentOS) distributions, you may have to
  −
yum install qt qt-x11
  −
if you get the error message
  −
xdsgui: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory
  −
or similar for libQtCore.so.4.
  −
If in case of RHEL or related distributions you don't know the name of the package, e.g.
  −
  yum provides "*/libQtCore.so.4"
  −
would tell you about it.
      
'''Ubuntu''' needs the libglu1-mesa package if you get the error message
 
'''Ubuntu''' needs the libglu1-mesa package if you get the error message
2,393

edits

Cookies help us deliver our services. By using our services, you agree to our use of cookies.

Navigation menu