Cookies help us deliver our services. By using our services, you agree to our use of cookies. More information

Changes

From CCP4 wiki

Coot

1,945 bytes removed, 13:16, 2 February 2017
remove some obsolete stuff
==== Example: installing a 64bit nightly CentOS5 binary build on 64bit SL6.1 ====
First of all, SL (Scientific Linux) is a derivative of RHEL, as is CentOS. So all three OSs behave exactly the same.
The binaries with "x86_64" binaries are for 64bit systems; the "i386" binaries are for 32bit systems. Since my notebook is 64bits ("uname -a" reports "x86_64" more than once), I download ftp://turn5.biologie.uni-konstanz.de/coot/software/binaries/nightlies/pre-release/coot-0.7-pre-1-revision-3999-binary-Linux-x86_64-centos-5-python-gtk2.tar.gz (the main server is slow, so I use the mirror). As root, I "cd /usr/local/src" and un-tar. Next, have to find out which libraries are missing. This can be achieved by (''note the use of LD_LIBRARY_PATH in the second command - do not permanently modify LD_LIBRARY_PATH !''):
[root@localhost]# cd coot-Linux-x86_64-centos-5-gtk2-python
[root@localhost]# LD_LIBRARY_PATH=lib ldd bin/coot-real | grep found
and make it executable with
chmod a+x /usr/local/bin/coot
 
=== Installation on Debian/Ubuntu from debian archive files ===
As an alternative, you might wish to exploit the debain dpkg/apt/synaptic package management system on Ubuntu and other Debian linux distributions using (unofficial)
[http://diablo.ucsc.edu/~wgscott/debian/coot_hardy/ pre-compiled debian packages for coot and its dependencies]. (These will be discontinued when official packages become available.)
 
To do so, simply download the deb files and install with the command
 
sudo dpkg -i *.deb
 
dpkg will complain if a dependency is missing rather than install a broken program.
 
=== Packages for Ubuntu ===
 
A pre-packaged version of Coot (0.7-pre-1) for Ubuntu is available from mok0's Personal Package Archive (PPA) on Launchpad. Currently, packages for Ubuntu 10.04 (Lucid) and 10.10 (Maverick) are available.
 
To install the coot package on your system, you first need to install the public key for mok0's PPA:
 
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1DC81A57
 
Next, add the PPA repository to your /etc/apt/sources.list file:
 
sudo add-apt-repository ppa:mok0/ppa
 
That's it! Now, you should be able to:
 
apt-get update && apt-get install coot
 
This version of Coot only supports the Python scripting language.
 
=== Mandriva Installation ===
 
To install the coot on Mandriva 2010.0 use the ubuntu distribution:
tar zxf coot-0.6.2-binary-Linux-i686-ubuntu-8.04.1-python-gtk2.tar.gz
 
in the .cshrc file:
alias coot 'source /prog/CCP4/ccp4-6.1.13/include/ccp4.setup-csh ; /prog/coot-Linux-i686-ubuntu-8.04.1-gtk2-python/bin/coot'
 
 
=== Converting to rpm packages ===
You can convert any debian package file into an rpm file using the program ''alien''. I have done this and have made the [http://diablo.ucsc.edu/~wgscott/debian/rpm/coot/ resulting packages] available.
=== Installation from source code via autobuild scripts ===
1,249
edits

Navigation menu